siunitx — outdated

Mit TeXLive 2011 kam ein kleines Problem:

--- TeX said ---
! siunitx error: "support-outdated"
!
! Support package expl3 too old.
!
! See the siunitx documentation for further information.
! For immediate help type H .
!...............................................


In ersten TL-Set waren einige LaTeX 3 Pakete nicht enthalten, die siunitx benötigt. Mittlerweile wurde das auf der tex-live Mailingliste gepostet und die repositories wurden aktualisiert. Ein einfaches aktualisieren der lokalen TL via tlmgr reicht aus um diesen Fehler zu beheben. Und da sage doch noch jemand die Distributionsverwaltung bei TeX wäre langsam! (Drei Tage ist nicht wirklich langsam oder?)

 Update: Ich habe gerade erfahren (danke Andi), dass wenn man von TL 2009 auf 2011 updatet und dann die l3-Packages installieren will es noch  ein Paket namens latex3-collection gibt, das sich mit den neuen (richtigen) Paketen beißt. Dieses muss deinstalliert werden. (Nutzer, die eine reine TL 2011 Installation haben (als komplett neu aufgezogen) sind davon nicht betroffen.)

Dieser Beitrag wurde unter (La)TeX abgelegt und mit verschlagwortet. Setze ein Lesezeichen auf den Permalink.

Ein Kommentar zu siunitx — outdated

  1. Clemens says:

    Es gibt übrigens Pakete, deren aktuelle Versionen noch immer nicht in TL 2011 enthalten sind. Z.B. bei chemfig noch v0.4b statt v1.0. Ich hab den Verdacht, dass das hauptsächlich Pakete betrifft, deren Update kam, während TL 2010 schon eingefroren war und TL 2011 noch nicht veröffentlicht.
    Das ist übrigens keine Kritik an TL und dem Team. Die machen tolle Arbeit :)

Hinterlasse eine Antwort

Deine E-Mail-Adresse wird nicht veröffentlicht. Required fields are marked *

*

You may use these HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>